Memory Access Violation caused when canceling export presentation to movie file to many times.

Home Forums Bug Report Memory Access Violation caused when canceling export presentation to movie file to many times.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #9505
    Leland Braun

    The product works great, except when I canceled export presentation to movie file to many times.

    Work around: (1) Forced to run product on another computer because of windows registry problems. (2) I make sure my video file is the right size before doing an export presentation and avoid doing a cancel when in-progress.

    Request: (1) need a clean un-install to help with product re-install (2) need cancelation cleanup routine to clean up windows registry problems caused by me canceling the export presentation to movie file too many times.

    I interrupted an export presentation to movie file 3 times, and each time an “image/coin” was posted on my desktop. I deleted the “image/coin” on the desktop and tried again, I was canceling the export to reduce the movie size. The first two times worked fine. The third time, I was unable to preview or play presentation before doing another export, kept getting Memory access violation. Had I not canceled the export so many times, I would have been fine. I tested the same file on my other computer and it works great. I believe the problem to be in the cancelation cleanup routine.
    I tried uninstalling/reinstalling the product on the computer having the problems. I could never get the windows registry cleaned up. I first tried a normal uninstall, rebooted the computer, and checked the registry. The windows registry still had some slide effect entries even after I did a un-install of the product. When I reinstalled the product, it did not ask me for the product key; and when trying to do a preview or play presentation I would get a memory access violation.

    Thk U for your help.


    Thanks for the detailed report.

    I’ll do some checks this week. I’ll keep you informed.


    I checked a little bit your issue:

    – image/coin.png: I fixed that. It was a debug image I created to fix a bug and it should not be in the official release… It will be removed on next release.

    – Regarding registry: The export to movie process does not use the registry, so I don’t think the problem comes from that. The only thing the uninstall process does not delete is the license key and some window positions. (for convenience)

    – Can you tell me on which step usually you cancel the export? Is it when the slideshow is created, when exporting inner movies when creating the sound or on the final step?


    Leland Braun

    1. “add slide”, picture + movie + 3d text, select a background, then save presentation.
    2. Play presentation, it works fine.
    3. Touch movie on slide and change “Advance Slide Properties”. Checked “Automatically after” 170 seconds (length of movie)
    4. Save project. Play presentation, it works file.
    5. Select “file/Export Presentation”
    Export Wizard:
    Select “Export presentation” to a movie file…
    Set filename: myfile.avi, then select “next”
    “Movie exportation is time consuming…”, select “next”
    Exporting Data: * My workaround is not to cancel this step *
    I select “cancel” here.
    Because the movie exportation is taking so long, I cancel the process. Reduce the movie size, update the slide and try again. The third time I canceled the process; and try again, it fails with Memory Access Violation.

    I tried creating a new slide
    1.“add slide”, picture + movie + 3d text, select a background, then save presentation.
    Note: when adding the movie it no-long shows a movie image.
    2.Preview and Play presentation both fail with Memory Access Violation.
    I tried creating more new slides and all Preview and Play presentation fail with Memory Access Violation.
    I tried un-installing and re-installing with no success.

    What’s important to note is the movie image no-longer appears when adding to a new slide. I installed the program on another computer and it works fine when adding the same movie to a new slide).
    My workaround is not to cancel the Exporting Data step.
    I would like to move the program back to the original computer, but the un-install and re-installed does not clear the Memory Access Violation for Preview and Play presentation for any slide type.
    If you un-install the program, then use regedit and search for “slide effect “ you can see the registry entries that were not deleted.

    Recommendation for Exporting Data step:
    “Movie exportation is time consuming…”, select “next”
    When user selects next to process, disable the “cancel” button.


    thanks for the details.

    Still unable to reproduce the problem :/

    Can you send me the content of your registry please? (on the faulty computer) (use regedit then menu File/Export…)

    Please send me the exported file to thanks!

    Leland Braun

    Already cleaned the registry a second time and got the program to work on the faulty computer. This was what I did:

    Unsuccessful First pass (original request): Un-installed the program, then used regedit and search for “slide effect” and deleted all these entries, then Cleaned the registry using a registry cleanup tool. Re-installed the program, tried it and continued to get “Memory Access Violations”.

    Successful Second pass (Update): Got the program to work on the faulty computer. The program was un-installed at this point and I made a second pass using regedit search “slideeffect” (notice no space between slide and effect) and delete all these entries, then Cleaned the registry using a registry cleanup tool. Re-installed the program and now it works:

    What I noticed when doing this second pass was an entry that was pointing to a file that was no-longer available in a temp folder, the registry entry look something like this (sorry, should of wrote it done): .. Data: AppData\local\Temp\launcher.exe se.exe

    I have routines on the faulty computer that cleanup …/AppData/local/Temp directories and other Temp directories. Why the registry entry was not deleted when the file was deleted is unknown?

    Testing that I did after I got it to work: I monitored my C:\Users\starman\AppData\Local\Temp\SlideEffect folder, while building new slides and selected “cancel” during the Exporting Data” step where I was having problems. I tried this 7 times and unable to reproduce the problem.

    Best Guess: The Memory Access Violations were caused when the program made a request for the launcher.exe file that was no-longer in the Temp directory because the registry was not updated when the file was deleted.

    Please ignore my previous recommendation to disable the cancel button.

    Thanks for your help the program is now working



    Thanks for the detailed answer (it helps me more than “IT DOES NOT WORK!!!!!” from some customers 😉 ).

    launcher.exe and se.exe are copied in the temp directory when running a standalone executable presentation, but not when the presentation is playing directly in Slide Effect software.. that’s strange… it should not interfere.

    But anyway, you are right I will double check I delete everything in the registry when uninstalling the software for the next version.

    Thanks and have a nice weekend.



    What do you mean by ACCESS MEMORY VIOLATION..Just purchase the standard product. thks

    Leland Braun

    The slide-effect program works fine; it is a good tool to use. The slide-effect program was a victim of my cleanup process (zcleanmgr.exe).

    The Memory Access Violation or Internal application error was triggered by me (the user) having an automated background cleanup process that deleted files in temp working folders (this process was coded/created by me) – this cleanup process ran at the same time I was using the slide-effect program.

    The problem was my cleanup process deleted all the temp files in the temp working folders, but failed to check for “file in-use” status before deleting the file which caused the windows registry entry for the file not to be deleted.

    So, when I ran the slide-effect program it was aware the file registry entry was available, but was unaware my cleanup process deleted the real file – this triggered slide-effect internal application error (Memory Access Violation) to be display because the real file was unavailable.

    Action taken by me: I corrected my cleanup process to always check for “file in-use” before deleting a temp file.

    Example of a similar windows provided cleanup process would be “cleanmgr.exe”

    Again, the slide-effect program works fine; it is a good tool to use.

Viewing 9 posts - 1 through 9 (of 9 total)
  • The forum ‘Bug Report’ is closed to new topics and replies.